the_content no funciona

No muestra el contenido en editor es decir tengo una imagen que he subido usando agregar medios de comunicación en la parte del editor que no se aparece por favor ayuda...se muestra la imagen pero no el contenido que tengo el el código como sigue:
 <?php if ( get_post_type() == bags ) { ?>

           <?php the_post_thumbnail(); ?>

          <?php } ?>
    <?php } ?>

   <?php if ( get_post_type() == books ) { ?>

           <?php the_content('editor'); ?>
               <?php the_post_thumbnail(); ?>


          <?} ?>
    <?php } ?>
Yo m usarlo para posttypes donde books es un postname.


Solución

Sin querer ser descortés: deberías empezar leyendo algunos tutoriales en PHP. (Más probablemente) es lo que quieres hacer en tu pregunta:
<?php
if ('bags' == get_post_type())
    the_post_thumbnail();
elseif ('books' == get_post_type()) {
    the_content('editor');
    the_post_thumbnail();
}
?>
Es este trabajo (como quieras)..




Problemas relacionados

Detener análisis shortcodes

¿Envoltura the_content() en articleBody etiqueta de esquema?

the_content no funciona en uno de dos sitios multisitio

Lo que los filtros se aplican a la función the_content.

¿Cómo agrego la imagen recomendada a the_content después del primer párrafo.

¿Por qué no muestra el contenido de the_content()?

Enlaces en the_content no vinculados

Función condicional para excluir la primera imagen de contenido, no funciona

Filtros y publicar contenidos, especiales personajes

Generación de leads con Cookies de Wordpress

Función para envolver the_content en un div

the_content devuelve en blanco cuando se agregan datos de SEO

Source: Stack Exchange Inc; License: cc by-sa 3.0 Contacto / Contact